ryanpstenmark
Jun 18, 2018

Render kernels reloading on each frame

3 comments

Edited: Jun 19, 2018

Hi,

 

I am attempting to render an animation. The local node behaves normally, but remote nodes reload their render kernels every frame (see attached)

-- which sort of defeats the point of a KERNEL, but whatever. Anyway, this really slows down the render speed, since ~95% of the time spent per frame is used building kernels instead of rendering the scene.

 

This occurs on my Windows 7 x64 node running x2 4GB RX550s and Blender 2.79b (current stable version as of 06/16/18.)

 

Am I missing something? How can I fix this?

James
Jun 19, 2018

Hi Ryan,

I'm not that familiar with the RX550, but on most of my tests using Nvidia this kernel building stage is fairly quick and doesn't take up so much of the overall render time.

As far as what I can see from your post, you're not missing anything and using CrowdRender correctly, it seems as though your long kernel build times might be specific to radeon cards -> https://blender.stackexchange.com/questions/97259/long-loading-render-kernels-on-opengl-with-amd-pro-duo

 

The reason the kernels are recompiled on each frame is that our addon doesn't yet have tight enough integration with cycles to load the kernels once and then just request parts of each frame to render. We're working on a solution to this so that we can do just that though so stay tuned :D. There will be improvements coming that will hopefully eliminate the need to re-compile the kernels.

 

ryanpstenmark
Jun 19, 2018

Thank you for the fast response James.

 

I should specify that my kernel build times aren't unusually long. This scene is really basic; each frame takes maybe a second to render without the overhead of rebuilding the kernel. With a sufficiently complex scene, kernel rebuild time would become negligible relative to render time.

 

I am looking forward to progress on this issue. My only other complaint is that nodes are sometimes finicky to resync, but even still CrowdRender is the best solution to distributed rendering with Blender that I've found so far. Keep it up!

James
Jun 19, 2018

Hi Ryan,

Thanks for the update :)

v015 should be released in about a week from now and should be a lot better in many regards. Resyncing should hopefully have been improved as well.

New Posts
  • pinthenet
    8 hours ago

    (I tried to post this as a possible bug report but must have done something wrong as I never got a confirmation or response - over a week ago now) I have 2 machines: Local: i7-6700K 4GHz/32gb/GTX1660Ti/Windows10 64bit Remote: i7-4770K 3.5GHz/32gb/GTX1660/Windows10 64bit (both have the latest Nvidia drivers) With crowd-render 2.0 I rendered a 500 frame animation. It took over twice as long as an F12 render & I found 4 or 5 blank frames. After 2.1 was released I removed 2.0, installed 2.1 and tried again. I switched to manual load balancing (0.6 for local, 0,4 for remote). Rendering still took as long - up to 19s per frame as before. The balancing seemed to have an effect, but there was a noticeable colour difference between (I assume) the locally-rendered and the remotely-rendered parts. I also found that frame 2 was blank (I stopped the rendering after this frame). On closer inspection of the logs (local attached, I couldn't attach the 2nd log) I found that in the local log Frame 0 was processed twice and Frame 3 wasn't listed (the missing frame was frame 2). The remote log seemed to be complete. In one other test I had a frame with one part completely white. I couldn't find any other reference to this type of result so maybe I have a system problem?
  • k.vissers
    8 hours ago

    As the title suggests, the connected computer does not render. It's shown to me, I can connect and sync to it, but when I click render, only the local machine renders. Even if I turn off the local computer, nothing happens on the other computer. Am i missing something? BTW i love this concept! Hope to see it grow :)
  • craigdvance
    6 days ago

    With Blender 2.80 official release candidate and pretty much any version of crowdrender, I can not get my network machines to sync. I can find them and begin to sync but it always fails. Well mostly it fails, sometimes it will work if I just repeatedly hit resync throughout the day. The test scene is in a shared network location and all textures and dependent files are packed in to the scene. I am maybe wrongly maybe correctly assuming this may be a network issue. When I install the add on , I get the start button and allow it through the firewall. I am running all the same versions on both machines I am testing with.

© 2019 Crowd Render Pty Ltd