gopper
Oct 5, 2017

first experience with crowdrender

7 comments

Hello,

so i have first time testet the crowdrender addon. First, i would say thanks guys for your work and time spend in this project.

 

I have three pcs at home. Because i always run out of vram by my projects, so i render normally with cpu.

 

The first problem was syncing the pcs. I had already installed the newest Blenderversion 2.79 at my workingpc. Then i installed the same version at the other two machines. They didn´t want syncing. As i installed all my addons and personally preferences at the other two machines (i copied and pastet the user preference folder from my working pc) it works and all synced.

 

Then the first try.

 

this ist the refrence render. Dont´t look at the headlight, it was only a quick testrender an i have forgotten to give the light a texture. It tooks about 10 minutes to render with my workpc with cpu.

 

Here the render with all three machines: It tooks about 9 minutes

 

As you can see, the enviroment lighting is there, but no textures at the renderclients. I think the part with textures is the local machine. I don´t know how and i couldn´t fix this until now.

 

But the next problem i will show you:

 

You see, this render tooks only about 8 minutes. There are even no textures at the lift part, but this render was with only two machines. And it tooks less time then that with three machines. Why is that? Now, the third pc, the Laptop has a lower cpu. I think the crowdrender addon took the image, divide it into pieces and then the clients render it out. But it seems this happens not dynamically. When one pc is ready, he do nothing.

For example: The teamrender feature by Cinema 4d. There render all cores of all renderclients simultaneous at the picuter (in case of a still). If you have f.e. the cpu`s with each four cores, then there are 12 buckets at the picture by rendering. So it doesn`t matter when one machine is slower than another, because the faster machine can render simple more buckets.

 

By the crowdrender addon in my case it is better, to disable the slower pc, as you can see, when i render it out with two equal machines, i have the best rendertime, because the slower machine doesn´t breake out the render.

 

Whats with the texture? I don´t know

 

So this was my first experience with the crowdrender. Since it is in develompment, there will sure comes huge improvements in future.

 

best regards

 

Mike

James
Oct 5, 2017

Hey Gopper! Thanks so much for posting, First the pink bits, you need to pack into blend file all your textures and then do what we call a resync, you need to hit the button that the red arrow is pointing at (see image below). This will send the file again to all the connected nodes and they will then have the textures packed into the blend file.

Second, the speed, have you tried doing more than one render of the image? The load balancer is really good when you do animations, we're improving it with a future version that will work similar to what is in C4D as you described, but for now it takes two to three renders before the load is balanced properly. You could try doing renders at a lower resolution to help the load balancer learn about your computers and the scene. Then you would be able to increase the resolution for a final render which should be perfectly balanced. If not, feel free to write a bug report and please include your files so we can investigate. You can report a bug at https://www.crowd-render.com/report-a-problem.

 

If you can get the textures to work, would you post this image again in this thread with the render as it should be?

It would be awesome to share your work :D I like the bike!

 

Location of resync button

 

gopper
Oct 5, 2017

Ah, ok, when i get at home, i will try it again. Thanks alot for the fast anwer. So then i must searcht the texture for the headlight :)

James
Oct 5, 2017

You're welcome and yes please! Would love to see the finished image :). Happy to help out with it if you have any more issues too.

gopper
Oct 5, 2017

By the way, is it in future releases in planning that i can see the progress of the render in the pictureviewer, so how it is when i render it normally?

James
Oct 5, 2017

Hi, yes, we're not there yet, but this is planned, so many people have asked for it we dare not ignore them. 0.1.2 will be released without this but we're looking at it for a future release. Stay tuned. :D

gopper
Oct 5, 2017

Hello again,

so, here is the final render from the bike in a real scene. I renounced of the post production, because i think its going mainly around the renderings. The picture below is the reference render, it tooks about 6.18 Minutes.

 

then i rendered it with the same machines then described in the top of the threat. Here it tooks 4.48 minutes to render. Then i rendered the same picture without any changes again and it tooks only 4.08 minutes. So it works with the correct delivery of packages to the different machines.

 

I must restart the pcs a view times, because i had trouble with the sync. The Laptop freezed by 1 percent sync, and the other pc didn´t get a connection. But after a few restarts it works.

 

So so far with my first render.

James
Oct 5, 2017

Hi Gopper, great work :) I also think I have found what is causing the problems with sync. We'll be releasing a patched version of the pre-release to all the registered testers next week after we've done some more testing on it.

New Posts
  • pinthenet
    8 hours ago

    (I tried to post this as a possible bug report but must have done something wrong as I never got a confirmation or response - over a week ago now) I have 2 machines: Local: i7-6700K 4GHz/32gb/GTX1660Ti/Windows10 64bit Remote: i7-4770K 3.5GHz/32gb/GTX1660/Windows10 64bit (both have the latest Nvidia drivers) With crowd-render 2.0 I rendered a 500 frame animation. It took over twice as long as an F12 render & I found 4 or 5 blank frames. After 2.1 was released I removed 2.0, installed 2.1 and tried again. I switched to manual load balancing (0.6 for local, 0,4 for remote). Rendering still took as long - up to 19s per frame as before. The balancing seemed to have an effect, but there was a noticeable colour difference between (I assume) the locally-rendered and the remotely-rendered parts. I also found that frame 2 was blank (I stopped the rendering after this frame). On closer inspection of the logs (local attached, I couldn't attach the 2nd log) I found that in the local log Frame 0 was processed twice and Frame 3 wasn't listed (the missing frame was frame 2). The remote log seemed to be complete. In one other test I had a frame with one part completely white. I couldn't find any other reference to this type of result so maybe I have a system problem?
  • k.vissers
    8 hours ago

    As the title suggests, the connected computer does not render. It's shown to me, I can connect and sync to it, but when I click render, only the local machine renders. Even if I turn off the local computer, nothing happens on the other computer. Am i missing something? BTW i love this concept! Hope to see it grow :)
  • craigdvance
    6 days ago

    With Blender 2.80 official release candidate and pretty much any version of crowdrender, I can not get my network machines to sync. I can find them and begin to sync but it always fails. Well mostly it fails, sometimes it will work if I just repeatedly hit resync throughout the day. The test scene is in a shared network location and all textures and dependent files are packed in to the scene. I am maybe wrongly maybe correctly assuming this may be a network issue. When I install the add on , I get the start button and allow it through the firewall. I am running all the same versions on both machines I am testing with.

© 2019 Crowd Render Pty Ltd